WordPress 2.5.1 別升級 Flash 10

若是有朋友仍在使用 WordPress 2.5.1,升級最近釋出的 Flash Player 10 之後,會發現按下「選取預上傳檔案」沒作用,以至於無法上傳檔案。

因 WordPress 所使用的第三方程式庫 SWFUploadFlash Player 10 環境下無法正常運作,而 2.5.x 版本沒有地方能夠將上傳檔案的功能切換回預設的上傳模式,則是個缺憾。當然,若您是使用 2.6.x 版本的 WordPress 則能夠切換回瀏覽器的預設單檔上傳模式。

嗯…如果一時手快,已經升級了怎麼辦呢?別擔心,我們有兩種解法:

  1. 下載舊的 Flash Player 9 回來安裝。
    這個方法需要下載近一百 MB 的舊版 Flash Player 9 壓所檔,因所有的系列與平台版本全包在一起供開發人員測試下載用。下載鍊結:Archived Flash Players available for testing purposes
  2. 下載專門給 WordPress 2.5.x 版本使用的 No Flash Uploader 外掛並啟用之。
    這時候就很感謝 WordPress 有強大的社群啦!

後語:這裡所指的 Flash Player 10 版本號碼為 10.0.12.36,若日後解決了這問題再行回報。

6 replies on “WordPress 2.5.1 別升級 Flash 10”

  1. 我有去挖 SWFUpload 的討論區,看起來 Adobe 新加的這個安全限制不會拿掉了。SWFUpload 以後應該會用 overlay 的方法繞過這個問題。 

  2. 我在你回覆wp正體中文交流所那篇之後,參考了一下WP社群的說法
    http://wordpress.org/support/topic/177127

    目前的情況很尷尬
    adobe堅持拿掉過去以來的原有功能,認為那是必要的安全更新–>不改
    WP堅持不會為了adobe客製化,不想幫別人擦屁股–>不改
    暫時只有No Flash Uploader 是妥協解的樣子

    沒想到我又要用到No Flash Uploader ,好不容易才讓flash可以動的…

Comments are closed.

%d bloggers like this: